Backup-Probleme

Nachdem ich das Projekt „Zentralbackup auf Tapelibrary“ erstmal zugunsten des Projektes „CD-Regal“ zurückgestellt habe, sicherte ich bis vor kurzem meine Daten noch direkt von meinem Arbeitsplatz-PC auf LTO1-Bänder. „Sicherte“, weil sich vor ein paar Tagen das Windows-XP-eigene Backuptool standhaft weigerte, auf Bänder zu schreiben. Nach einigen Tests bin ich mir nun relativ sicher, daß das Problem nicht am Laufwerk oder den Bändern, sondern vielmehr an Windows selbst liegt. Einerseits ist das natürlich gut, weil ich keinen Ersatz für ein defektes Laufwerk beschaffen muß, andererseits ist das ziemlich schlecht, weil ich keine Ahnung habe, wie ich dem Problem beikommen sollte. (Zumal Windows ja keine aussagekräftigen Fehlermeldungen oder Logfiles erzeugt.) :(

Da natürlich zügig ein Ersatz-Backup her mußte, habe ich mir erstmal eine externe 1TB-Festplatte besorgt. Die hat zwar (auch) einen eSATA-Anschluß, aber da mein Computer sowas nicht hat, muß ich auf den USB-2.0-Anschluß ausweichen. Und darüber ist das einfach nur grausig langsam: Obwohl es „nur“ um knapp 400 GB geht, rödelt das Laufwerk in Summe inzwischen wohl schon länger als 24h und ist immer noch nicht fertig. :( Ich weiß nicht, woran es genau liegt – an der Festplatte, am USB-Bridge-Chip, an der USB-Verbindung oder mal wieder an Windows – Fakt ist aber, daß die Sache bei vielen kleinen Dateien besonders zäh läuft.

Eine Dauerlösung ist das jedenfalls nicht. Mal schauen, welche Lösungen sich noch so ergeben…

4 Kommentare auf “Backup-Probleme

  1. Kurzer Erfahrungswert meinerseits: habe mir vor ca. 1 Monat auch mal eine 1-TB-Platte angeschafft, um endlich mal mein OS X zu sichern. Klar: Äpfel-mit-Birnen-Vergleich ;-)

    Ich habe die Zeit nicht gestoppt, allerdings war es deutlich unter 6 Stunden (um mal bei Deiner Größenordnung zu bleiben), ich schätze so ca. 2 Stunden. Seit dem dürfte TimeMashine nur noch inkrementelle Sicherungen anlegen. Eventuell finde ich ja noch ein Logfile von der Erstsicherung, dann kann ich ja mal genau hinschauen…

    Daten & Fakten:
    HD: 1 TB, gemäß Verpackung USB 2.0
    Backup-SW: TimeMashine
    Initial-Backup: ca. 100 GB auf dem zu sichernden System

  2. *hmpf*
    Ich hab’s befürchtet, da ist wieder mal gewaltig was faul. :(
    Ich vermute ja, daß die Platte weder Caching noch NCQ noch sonstwas macht. Das würde auch die brutal einbrechende Geschwindigkeit bei kleinen Datein erklären: Datei schreiben, Kopf umpositionieren, FAT schreiben, Kopf umpositionieren, nächste Datei schreiben…
    Außerdem schnellt beim Kopieren die Systemlast unnatürlich nach oben. Alles Mist…! :(

  3. Also… ich mach mein Backup auf ein externes FW800-Gehäuse mit zwei gespiegelten 1 TB-Platten. Also simples RAID 1. Mein initiales Backup (ca. 470 GB) dauerte mit arsync (einem rsync mit GUI für OS X) ca. 3 Stunden. Seitdem geht alles nur noch inkrementell und das selten länger als 20 Minuten lang.

    Da dürfte natürlich im FW800 ein Großteil der Performance anzulasten sein und andererseits HFS+ (statt FAT)…

    Aber Äpfel und Birnen halt…

1 Pings/Trackbacks für "Backup-Probleme"

Schreibe einen Kommentar

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden .